Wednesday, March 2, 2011

How switching works - L2 & L3 responsibilities

Topology :



Objective :

** Swtiching process and L2 Encapsulation does not necessary relate, and the problem at one stage does not necessary relate to other stage.
** So if L2 Encapsulation is broken does not necessary "Routing is broken"


Configuration of Part of Diagram : Color filled Box


R1#

interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto


interface FastEthernet1/0.13
 encapsulation dot1Q 13
 ip address 10.1.13.1 255.255.255.0



R3#
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto


interface FastEthernet1/0.13
 encapsulation dot1Q 13
 ip address 10.1.13.3 255.255.255.0


=>  Basic reachability is there and no Layer 2 issues now.

R1#ping 10.1.13.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.13.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/36/80 ms


R3#ping 10.1.13.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/34/80 ms


Little bit Debug will give more clarity :

R1#sh deb
ARP:
  ARP packet debugging is on
Generic IP:
  IP packet debugging is on


** So i enabled "IP Packet and Arp" process to track the status how exactly Routing and Layer
2 process happens and which is key to identify.


R1#ping 10.1.13.3 rep 1
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 10.1.13.3, timeout is 2 seconds:
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 88/88/88 ms


R1#
*Mar  1 00:56:15.123: IP: tableid=0, s=10.1.13.1 (local), d=10.1.13.3 (FastEthernet1/0.13), routed via FIB
*Mar  1 00:56:15.127: IP: s=10.1.13.1 (local), d=10.1.13.3 (FastEthernet1/0.13), len 100, sending
*Mar  1 00:56:15.203: IP: tableid=0, s=10.1.13.3 (FastEthernet1/0.13), d=10.1.13.1 (FastEthernet1/0.13), routed via RIB
*Mar  1 00:56:15.207: IP: s=10.1.13.3 (FastEthernet1/0.13), d=10.1.13.1 (FastEthernet1/0.13), len 100, rcvd 3



** Now i am pinging UNKNOWN ip address to track and identify the switching and Routing difference.


R1#ping 10.1.13.100 rep 1
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 10.1.13.100, timeout is 2 seconds:

*Mar  1 00:56:55.767: IP: tableid=0, s=10.1.13.1 (local), d=10.1.13.100 (FastEthernet1/0.13), routed via RIB
*Mar  1 00:56:55.767: IP: s=10.1.13.1 (local), d=10.1.13.100 (FastEthernet1/0.13), len 100, sending
*Mar  1 00:56:55.775: IP ARP: creating incomplete entry for IP address: 10.1.13.100 interface FastEthernet1/0.13*Mar  1 00:56:55.775: IP ARP: sent req src 10.1.13.1 cc00.08ec.0010,
                 dst 10.1.13.100 0000.0000.0000 FastEthernet1/0.13 <<- MAC address*Mar  1 00:56:55.779: IP: s=10.1.13.1 (local), d=10.1.13.100 (FastEthernet1/0.13), len 100, encapsulation failed.
Success rate is 0 percent (0/1)
R1#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.1.13.3              22   cc01.08ec.0010  ARPA   FastEthernet1/0.13
Internet  10.1.13.1               -   cc00.08ec.0010  ARPA   FastEthernet1/0.13
Internet  10.1.13.100             0   Incomplete      ARPAR1#

------------// Cisco Express Forwaridng  //------------

** L3 Routing is bi-directional process in general ( R1 --> R3 --> R1 )
 That means completely separate process.
** L2 switching is different, because of STP working model (Paths will be syncronous) is different than L2 Routing. If R1 Routing lookup is enough to Route the packet to R3


Simple example :
Now i added Loopback on both the Routers.

R1(config)#int lo1
R1(config-if)#ip add 1.1.1.1 255.255.255.255



R3(config)#int lo3
R3(config-if)#ip add 3.3.3.3 255.255.255.255


R3#ping 1.1.1.1 rep 2
Type escape sequence to abort.
Sending 2, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:

*Mar  1 01:25:45.091: IP: s=3.3.3.3 (local), d=1.1.1.1, len 100, unroutable.
*Mar  1 01:25:47.091: IP: s=3.3.3.3 (local), d=1.1.1.1, len 100, unroutable.
Success rate is 0 percent (0/2)



R3#sh ip route 1.1.1.1
% Network not in table


** When it dropss packet by default it should genenrate ICMP message
Add Static Routing :

R3(config)#ip route 1.1.1.1 255.255.255.255 10.1.13.1
R1(config)#ip route 3.3.3.3 255.255.255.255 10.1.13.3


R1(config)#do ping 3.3.3.3 so 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/33/76 ms
R1(config)#


Routing Vs CEF ::

R1(config)#do sh ip route 3.3.3.3
Routing entry for 3.3.3.3/32
  Known via "static", distance 1, metric 0
  Routing Descriptor Blocks:
  * 10.1.13.3
      Route metric is 0, traffic share count is 1


** Based on input details CEF can do Input balancing based on the entries.
** By default CEF can do load balancing between source and destination pair as well.
** Switching alway differentiate Locally generated traffic and Transit traffic.
** Local traffic is always process switched and transit should use Fast or CEF


R1(config)#do sh ip cef exact-route 1.1.1.1 3.3.3.3
1.1.1.1         -> 3.3.3.3        : FastEthernet1/0.13 (next hop 10.1.13.3)


R1(config)#do sh ip cef exact-route 1.1.1.2 3.3.3.3
1.1.1.2         -> 3.3.3.3        : FastEthernet1/0.13 (next hop 10.1.13.3)
R1(config)#do sh ip cef exact-route 1.1.1.3 3.3.3.3
1.1.1.3         -> 3.3.3.3        : FastEthernet1/0.13 (next hop 10.1.13.3)

Over Lapping Routes :

R1(config)#ip route 3.3.3.3 255.255.255.255 10.1.13.2
R1(config)#ip route 3.3.3.3 255.255.255.255 10.1.13.4


** In this case Static metric will come into picture.

R1(config)#do sh ip route
Gateway of last resort is not set
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback1
     3.0.0.0/32 is subnetted, 1 subnets
S       3.3.3.3 [1/0] via 10.1.13.3
                [1/0] via 10.1.13.2

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.13.0 is directly connected, FastEthernet1/0.13


See the Output :::

R1(config)#do ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!.!.!
Success rate is 60 percent (3/5), round-trip min/avg/max = 52/74/92 ms


** Why packets dropped, because of Load balancing using Switching machanism.
** I just added to Secondary ip addresses again for CEF testing

R1(config)#int lo1
R1(config-if)#ip add 1.1.1.2 255.255.255.255 sec
R1(config-if)#ip add 1.1.1.3 255.255.255.255 sec
R1(config-if)#end


** packet drops will happend due to load blancing



Happy Labbing  ^_^

Subnet Mask in IGP for Loopbacks

Topology :



Configuration :

R1#

interface Serial0/0
 ip address 10.0.12.1 255.255.255.0

router eigrp 100
 network 0.0.0.0
 no auto-summary


router ospf 100
 router-id 11.11.11.11
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0


R2#

interface Serial0/0
 ip address 10.0.12.2 255.255.255.0

interface Serial0/1
 ip address 10.0.23.2 255.255.255.0

router eigrp 100
 network 0.0.0.0
 no auto-summary


router ospf 100
 router-id 22.22.22.22
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0


R3#

interface Loopback3
 ip address 3.3.3.3 255.255.0.0


interface Loopback33
 ip address 33.33.33.33 255.255.255.248

interface Serial0/0
 ip address 10.0.23.3 255.255.255.0
 clock rate 2000000


router eigrp 100
 network 3.3.0.0 0.0.255.255
 network 10.0.23.0 0.0.0.255
 network 33.33.33.32 0.0.0.7
 no auto-summary


router ospf 100
 router-id 32.32.32.32
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0


 Testing :

Related configuration :

R3(config)#do sh int lo33
Loopback33 is up, line protocol is up
  Hardware is Loopback
  Internet address is 33.33.33.33/29


Observe the output carefully :

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     33.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O       33.33.33.33/32 [110/129] via 10.0.12.2, 00:21:22, Serial0/0
D       33.33.33.32/29 [90/2809856] via 10.0.12.2, 00:12:11, Serial0/0
     3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O       3.3.3.3/32 [110/129] via 10.0.12.2, 00:21:22, Serial0/0
D       3.3.0.0/16 [90/2809856] via 10.0.12.2, 00:12:11, Serial0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.0.12.0 is directly connected, Serial0/0
D       10.0.23.0 [90/2681856] via 10.0.12.2, 00:32:09, Serial0/0

I want to reach 33.33.33.33 which is configured in R3 and this Network is learned by both IGP's EIGRP and OSPF.
So obviously i expect to reach by EIGRP as this is preferred and less AD value than OSPF.

R1#sh ip route 33.33.33.33
Routing entry for 33.33.33.33/32
  Known via "ospf 100", distance 110, metric 129, type intra area  Last update from 10.0.12.2 on Serial0/0, 00:17:52 ago
  Routing Descriptor Blocks:
  * 10.0.12.2, from 32.32.32.32, 00:17:52 ago, via Serial0/0
      Route metric is 129, traffic share count is 1

R2#sh ip route 33.33.33.33
Routing entry for 33.33.33.33/32
  Known via "ospf 100", distance 110, metric 65, type intra area  Last update from 10.0.23.3 on Serial0/1, 00:18:41 ago
  Routing Descriptor Blocks:
  * 10.0.23.3, from 32.32.32.32, 00:18:41 ago, via Serial0/1
      Route metric is 65, traffic share count is 1

Why it did not prefer to take the path by EIGRP ?
Have you noticed the mask information ?

Then you are good to go.

** Always longest match will be preferred first then followed by AD or metric values etc..
** So here OSPF took the advantage of taking / learning this as /32 but EIGRP still took as it is so it is still /29
** obviously OSPF is preferred.


How to fix this ?

Check how OSPF is treating Loopback interface details here :

R3(config)#do sh ip ospf inter l33
Loopback33 is up, line protocol is up
  Internet Address 33.33.33.33/29, Area 0
  Process ID 100, Router ID 32.32.32.32, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Check how EIGRP is treating Loopback interface details here :

R3(config)#do sh ip eigrp int l33
IP-EIGRP interfaces for process 100
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Lo33               0        0/0         0       0/1            0           0

** So there is a difference in treatment.
** So to advertise currect subnet mask for Loopbacks there are multiple ways to do this but

simple way is just change the Network type from Loopback to "Point-to-Point"

Solution:

R3(config)#int lo33
R3(config-if)#ip ospf network point-to-point
R3(config-if)#end

And the Routing table update is :

R1#sh ip route 33.33.33.33
Routing entry for 33.33.33.32/29
  Known via "eigrp 100", distance 90, metric 2809856, type internal  Redistributing via eigrp 100
  Last update from 10.0.12.2 on Serial0/0, 00:34:52 ago
  Routing Descriptor Blocks:
  * 10.0.12.2, from 10.0.12.2, 00:34:52 ago, via Serial0/0
      Route metric is 2809856, traffic share count is 1
      Total delay is 45000 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2

R2#sh ip route 33.33.33.33
Routing entry for 33.33.33.32/29
  Known via "eigrp 100", distance 90, metric 2297856, type internal  Redistributing via eigrp 100
  Last update from 10.0.23.3 on Serial0/1, 00:34:39 ago
  Routing Descriptor Blocks:
  * 10.0.23.3, from 10.0.23.3, 00:34:39 ago, via Serial0/1
      Route metric is 2297856, traffic share count is 1
      Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

** So this is just to make sure the behavior of these IGP protocols on how they treat the Network types based on media types. The same follows for 3.3.3.3 also


Happy Labbing  ^_^

Sunday, February 27, 2011

Frame-Relay & OSPF with different Network types

  ---------// OSPF & Frame-Relay //----------

Topology Diagram :


=> Interfaces details ( DLCI details can be found in Topology diagram )

R1(config-router)#do sh prot | e do
Global values:
  Internet Protocol routing is enabled
Serial0/0 is up, line protocol is up
  Internet address is 10.0.0.1/24
Loopback11 is up, line protocol is up
  Internet address is 11.11.11.11/32


R2(config-router)#do sh ip int brie | e un
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.0.0.2        YES manual up                    up 
Loopback22                 22.22.22.22     YES manual up                    up 
R2(config-router)#


R3(config-router)#do sh ip int brie | e un
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.0.0.3        YES manual up                    up 
Loopback33                 33.33.33.33     YES manual up                    up 



=> COnfigure and Build L2 & L3 mappings ( Frame-relay connectivity )
=> Now it's a Mesh topology R1 can reach R2 & R3
                            R2 can reach R1 & R3
       R3 can reach R1 & R2


Configuration : 

=> point-to-multipoint

R1(config-router)#do sh run int se 0/0
Building configuration...

Current configuration : 284 bytes
!
interface Serial0/0
 ip address 10.0.0.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 serial restart-delay 0
 clock rate 2016000
 frame-relay map ip 10.0.0.2 102 broadcast
 frame-relay map ip 10.0.0.3 103 broadcast
 no frame-relay inverse-arp
end


R1(config-router)#do sh run | s r o
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0


R2(config-router)#do sh run int se 0/0
Building configuration...

Current configuration : 284 bytes
!
interface Serial0/0
 ip address 10.0.0.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 serial restart-delay 0
 clock rate 2016000
 frame-relay map ip 10.0.0.1 201 broadcast
 frame-relay map ip 10.0.0.3 203 broadcast
 no frame-relay inverse-arp
end


R2(config-router)#
R2(config-router)#do sh run | s r o
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
R2(config-router)#


R3#sh run int se 0/0
Building configuration...

Current configuration : 264 bytes
!
interface Serial0/0
 ip address 10.0.0.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 serial restart-delay 0
 frame-relay map ip 10.0.0.1 301 broadcast
 frame-relay map ip 10.0.0.2 302 broadcast
 no frame-relay inverse-arp
end


R3#sh run | s r o
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
R3#


Check the Routing Table :

R1(config-router)#do sh ip ro os
     33.0.0.0/32 is subnetted, 1 subnets
O       33.33.33.33 [110/65] via 10.0.0.3, 00:06:48, Serial0/0
     22.0.0.0/32 is subnetted, 1 subnets
O       22.22.22.22 [110/65] via 10.0.0.2, 00:06:48, Serial0/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.0.0.2/32 [110/64] via 10.0.0.2, 00:06:48, Serial0/0
O       10.0.0.3/32 [110/64] via 10.0.0.3, 00:06:48, Serial0/0
R1(config-router)#


R2(config-router)#do sh ip ro os
     33.0.0.0/32 is subnetted, 1 subnets
O       33.33.33.33 [110/65] via 10.0.0.3, 00:06:08, Serial0/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.0.0.3/32 [110/64] via 10.0.0.3, 00:06:08, Serial0/0
O       10.0.0.1/32 [110/64] via 10.0.0.1, 00:06:08, Serial0/0
     11.0.0.0/32 is subnetted, 1 subnets
O       11.11.11.11 [110/65] via 10.0.0.1, 00:06:08, Serial0/0
R2(config-router)#


R3(config-router)#do sh ip ro os
     22.0.0.0/32 is subnetted, 1 subnets
O       22.22.22.22 [110/65] via 10.0.0.2, 00:05:31, Serial0/0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.0.0.2/32 [110/64] via 10.0.0.2, 00:05:31, Serial0/0
O       10.0.0.1/32 [110/64] via 10.0.0.1, 00:05:31, Serial0/0
     11.0.0.0/32 is subnetted, 1 subnets
O       11.11.11.11 [110/65] via 10.0.0.1, 00:05:31, Serial0/0
R3(config-router)#


Testing / Reachability :
R1(config-router)#do ping 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/22/48 ms
R1(config-router)#do ping 10.0.0.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/24/56 ms
R1(config-router)#


R2(config-router)#do ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/24/52 ms
R2(config-router)#do ping 10.0.0.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/17/48 ms
R2(config-router)#


R3#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/20/56 ms
R3#ping 10.0.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/23/68 ms
R3#


=> So things are working as expected till now. Life is good.
=> It's time to play now by changing the Network type to watch a big game here.
   There lies the tricks and concept behind the DR/BDR election process, how much it is dependent and how to tweak the parameters of network types & interface natural behavior to participate in Election process.
   It's quite natural that Election process will happen per situation and necessary only for those interface types ( Based on Media types )


 -----// point-to-Point //--------

R1(config-if)#ip ospf network point-to-point
R1(config-if)#
*Mar  1 02:06:42.187: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 02:06:42.191: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#


=> See the above reaction the movement we change the network type, they are not happy and walkout from neighborship. The reason behind is because of Hello & Dead timer value changes

Let us compare now :

R1(config-if)#do sh ip os int se 0/0
Serial0/0 is up, line protocol is up
  Internet Address 10.0.0.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5


R2#sh ip ospf interface se 0/0
Serial0/0 is up, line protocol is up
  Internet Address 10.0.0.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5


=> Hope you got the point here, both the interface types have mismatch in Hello & Dead timer values.
=> So can't agree each other, this is very important to form Neighborship.
So i just matched those values manually here

R1(config-if)#ip os hello-interval 30
R1(config-if)#ip os dead-interval  120


R1(config-if)#
*Mar  1 02:27:12.575: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
*Mar  1 02:27:13.131: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0 from LOADING to FULL, Loading Done
*Mar  1 02:27:22.871: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
*Mar  1 02:27:27.915: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from LOADING to FULL, Loading Done
*Mar  1 02:27:29.647: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from FULL to DOWN, Neighbor Down: Adjacency forced to reset
*Mar  1 02:27:29.815: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0 from EXCHANGE to DOWN, Neighbor Down: Adjacency forced to reset
*Mar  1 02:27:30.115: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from LOADING to FULL, Loading Done


=> Now they just come back and go down, so still stability is not there ( I need to research more on this )

Debug :

R1(config-if)#do deb frame packet
Frame Relay packet debugging is on
R1(config-if)#
*Mar  1 02:32:12.571: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from F                                                                 ULL to DOWN, Neighbor Down: Adjacency forced to reset
*Mar  1 02:32:14.971: Serial0/0(i): dlci 103(0x1871), pkt type 0x800, datagramsi                                                                 ze 68
*Mar  1 02:32:14.979: Serial0/0: broadcast search
*Mar  1 02:32:14.983: Serial0/0: Broadcast on DLCI 103  link 7
*Mar  1 02:32:14.983: Serial0/0(o): dlci 103(0x1871), pkt type 0x800(IP), datagr                                                                 amsize 128
*Mar  1 02:32:14.987: Serial0/0(o): dlci 102(0x1861), pkt type 0x800(IP), datagr                                                                 amsize 128
*Mar  1 02:32:15.023: broadcast dequeue
*Mar  1 02:32:15.023: Serial0/0(o):Pkt sent on dlci 103(0x1871), pkt type
0x800(IP), datagramsize 128
*Mar  1 02:32:15.023: broadcast dequeue
*Mar  1 02:32:15.023: Serial0/0(o):Pkt sent on dlci 102(0x1861), pkt type
0x800(IP), datagramsize 128


-----// point-to-multipoint nonbroadcast //--------

R1(config-if)#ip ospf network point-to-multipoint non-broadcastR1(config-if)#
*Mar  1 02:39:38.115: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 02:39:38.119: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Mar  1 02:39:42.671: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0 from LOADING to FULL, Loading Done
*Mar  1 02:39:52.931: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from LOADING to FULL, Loading Done
R1(config-if)#


R1(config-if)#do sh ip os neigh
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -        00:01:50    10.0.0.2        Serial0/0
3.3.3.3           0   FULL/  -        00:01:39    10.0.0.3        Serial0/0
R1(config-if)#
R1(config-if)#
R1(config-if)#
R1(config-if)#do ping 22.22.22.22

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/20/56 ms
R1(config-if)#do ping 33.33.33.33

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/25/56 ms
R1(config-if)#


=> Things are still working because we manually done the mapping job in L2 level, so there is no reachability issue by this.

=> Another fair game, now i am going to configure " ip ospf network point-to-multipoint non-broadcast" on R2

-------------
Before :

R2(config-if)#do sh ip os neigh
Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -        00:01:56    10.0.0.3        Serial0/0
1.1.1.1           0   FULL/  -        00:01:55    10.0.0.1        Serial0/0
R2(config-if)#
R2(config-if)#
R2(config-if)#ip ospf network point-to-multipoint non-broadcastR2(config-if)#
*Mar  1 02:47:36.151: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 02:47:36.159: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on Serial0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
R2(config-if)#
R2(config-if)#do sh ip os neigh


It will tear down the connections and come's back only for R3, because R3 is still "Broadcast" and R1 will NOT be neighbor any more. Because R1 also configured "Nonbroadcast"

R2(config-if)#do sh ip os neigh
R2(config-if)#
*Mar  1 02:48:02.631: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0 from LOADING to FULL, Loading Done


After some time : Still no connectivity to R1

R2(config-if)#do sh ip os neigh
Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -        00:01:57    10.0.0.3        Serial0/0

R2(config-if)#
BUT...BUT....i am still able to ping "R1"
How? because we are done with manual bindings like below config shows.


R2(config-if)#do ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/31/96 ms

R2(config-if)#do ping 11.11.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/28/88 ms

R2(config-if)#do sh run int se 0/0
Building configuration...

Current configuration : 298 bytes
!
interface Serial0/0
 ip address 10.0.0.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint non-broadcast
 serial restart-delay 0
 clock rate 2016000
 frame-relay map ip 10.0.0.1 201 broadcast
 frame-relay map ip 10.0.0.3 203 broadcast
 no frame-relay inverse-arp
end


R2(config-if)#
------------

=> In some situation we need to use 'Neighbor <ip>' command to tell the OSPF process whom to contact, the best practice is to configure on HUB Router rather Spoke.
=> HUB Router know to provide reachability with other neighbors, this is simple and no confusion to process.



Happy Labbing ^_^






Sunday, February 20, 2011

EIGRP Basics

Objective:

    How EIGRP metric influence the Routing from R2 --> R4 by changing the metric Values from Default to customized.
   We are going to change only DELAY rather bandwidth, this is easy to influence and verify the paths.


Topology:


Interface configuration ::

R1#sh prot | e do
Global values:
  Internet Protocol routing is enabled
Serial0/0 is up, line protocol is up
  Internet address is 10.0.12.1/24
Loopback1 is up, line protocol is up
  Internet address is 1.1.1.1/32


R2#sh prot | e do
Global values:
  Internet Protocol routing is enabled
Serial0/0 is up, line protocol is up
  Internet address is 10.0.23.2/24
Serial0/1 is up, line protocol is up
  Internet address is 10.0.24.2/24
Serial0/2 is up, line protocol is up
  Internet address is 10.0.12.2/24
Loopback2 is up, line protocol is up
  Internet address is 2.2.2.2/32


R3#sh prot | e do
Global values:
  Internet Protocol routing is enabled
Serial0/0 is up, line protocol is up
  Internet address is 10.0.23.3/24
Serial0/1 is up, line protocol is up
  Internet address is 10.0.34.3/24
Loopback3 is up, line protocol is up
  Internet address is 3.3.3.3/32


R4#sh prot | e do
Global values:
  Internet Protocol routing is enabled
Serial0/0 is up, line protocol is up
  Internet address is 10.0.24.4/24
Serial0/1 is up, line protocol is up
  Internet address is 10.0.34.4/24
Loopback4 is up, line protocol is up
  Internet address is 4.4.4.4/32


EIGRP Configuration ::


R1#sh run | s r e
router eigrp 1
 network 1.1.1.1 0.0.0.0
 network 10.0.12.0 0.0.0.255
 no auto-summary


R2#sh run | s r e
router eigrp 1
 network 2.2.2.2 0.0.0.0
 network 10.0.12.0 0.0.0.255
 network 10.0.23.0 0.0.0.255
 network 10.0.24.0 0.0.0.255
 no auto-summary


R3#sh run | s r e
router eigrp 1
 network 3.3.3.3 0.0.0.0
 network 10.0.23.0 0.0.0.255
 network 10.0.34.0 0.0.0.255
 no auto-summary


R4#sh run | s r e
router eigrp 1
 network 4.4.4.4 0.0.0.0
 network 10.0.24.0 0.0.0.255
 network 10.0.34.0 0.0.0.255
 no auto-summary


=> In order to reach 4.4.4.4 Network available in R4, R2 have to paths but based FD & Successors paths

R2#sh ip route 4.4.4.4
Routing entry for 4.4.4.4/32
  Known via "eigrp 1", distance 90, metric 2297856, type internal
  Redistributing via eigrp 1
  Last update from 10.0.24.4 on Serial0/1, 00:00:02 ago
  Routing Descriptor Blocks:
  * 10.0.24.4, from 10.0.24.4, 00:00:02 ago, via Serial0/1
      Route metric is 2297856, traffic share count is 1
      Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1


=> Check out the available paths here.

R2#sh ip eigrp top al
IP-EIGRP Topology Table for AS(1)/ID(10.0.24.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 1.1.1.1/32, 1 successors, FD is 2297856, serno 9
        via 10.0.12.1 (2297856/128256), Serial0/2
P 2.2.2.2/32, 1 successors, FD is 128256, serno 8
        via Connected, Loopback2
P 3.3.3.3/32, 1 successors, FD is 2809856, serno 57
        via 10.0.24.4 (2809856/2297856), Serial0/1
        via 10.0.23.3 (6905856/128256), Serial0/0
P 4.4.4.4/32, 1 successors, FD is 2246656, serno 55
        via 10.0.24.4 (2297856/128256), Serial0/1
P 10.0.12.0/24, 1 successors, FD is 2169856, serno 1
        via Connected, Serial0/2
P 10.0.24.0/24, 1 successors, FD is 2169856, serno 3
        via Connected, Serial0/1
P 10.0.23.0/24, 1 successors, FD is 6777856, serno 52
        via Connected, Serial0/0
        via 10.0.24.4 (3193856/2681856), Serial0/1
P 10.0.34.0/24, 1 successors, FD is 2681856, serno 58
        via 10.0.24.4 (2681856/2169856), Serial0/1

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

        via 10.0.23.3 (11897856/6777856), Serial0/0, serno 59

** Now i want ot influence the paths by calculating the existing Reported distance and Feasible distance
** So that i can LOAD-BALNCE the traffic to reach 4.4.4.4 by

               R2 -> R4 and
               R2 -> R3 -> R4


** I will change the Delay from 20000 to 10000 on  R3 ( S 0/1 ) Interfaces which takes to R4 paths.

Testing ::

R2#sh ip eigrp top al
IP-EIGRP Topology Table for AS(1)/ID(10.0.24.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 1.1.1.1/32, 1 successors, FD is 2297856, serno 9
        via 10.0.12.1 (2297856/128256), Serial0/2
P 2.2.2.2/32, 1 successors, FD is 128256, serno 8
        via Connected, Loopback2
P 3.3.3.3/32, 1 successors, FD is 2809856, serno 57
        via 10.0.24.4 (2809856/2297856), Serial0/1
        via 10.0.23.3 (6905856/128256), Serial0/0
P 4.4.4.4/32, 1 successors, FD is 2246656, serno 55
        via 10.0.24.4 (2297856/128256), Serial0/1  
        via 10.0.23.3 (7161856/2041856), Serial0/0 <<-----  Wow there are 2 paths meeting the requirements to become FS

P 10.0.12.0/24, 1 successors, FD is 2169856, serno 1
        via Connected, Serial0/2
P 10.0.24.0/24, 1 successors, FD is 2169856, serno 3
        via Connected, Serial0/1
        via 10.0.23.3 (7545856/2425856), Serial0/0
P 10.0.23.0/24, 1 successors, FD is 6777856, serno 52
        via Connected, Serial0/0
        via 10.0.24.4 (3193856/2681856), Serial0/1
P 10.0.34.0/24, 1 successors, FD is 2681856, serno 58
        via 10.0.24.4 (2681856/2169856), Serial0/1
        via 10.0.23.3 (7033856/1913856), Serial0/0, serno 59


R2#sh ip route 4.4.4.4  
Routing entry for 4.4.4.4/32
  Known via "eigrp 1", distance 90, metric 2297856, type internal
  Redistributing via eigrp 1
  Last update from 10.0.24.4 on Serial0/1, 00:00:33 ago
  Routing Descriptor Blocks:
  * 10.0.24.4, from 10.0.24.4, 00:00:33 ago, via Serial0/1   <<-- Still only one path and NO traffic load-balance

      Route metric is 2297856, traffic share count is 1
      Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1


** Let us meet the requirement again to install to Routes in Routing table so i will change the Delay from 20000 to 10000 on  R2 ( S 0/0 )

R2#sh ip route 4.4.4.4
Routing entry for 4.4.4.4/32
  Known via "eigrp 1", distance 90, metric 2297856, type internal
  Redistributing via eigrp 1
  Last update from 10.0.23.3 on Serial0/0, 00:00:03 ago
  Routing Descriptor Blocks:
  * 10.0.24.4, from 10.0.24.4, 00:00:03 ago, via Serial0/1
      Route metric is 2297856, traffic share count is 1
      Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1
    10.0.23.3, from 10.0.23.3, 00:00:03 ago, via Serial0/0   <-- We made it now we have 2 paths to reach 4.4.4.4

      Route metric is 2297856, traffic share count is 1
      Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2


R2#sh ip cef exact-route 2.2.2.2 4.4.4.4
2.2.2.2         -> 4.4.4.4        : Serial0/0 (next hop 10.0.23.3)
R2#sh ip cef exact-route 2.2.2.1 4.4.4.4
2.2.2.1         -> 4.4.4.4        : Serial0/1 (next hop 10.0.24.4)
R2#sh ip cef exact-route 2.2.2.3 4.4.4.4
2.2.2.3         -> 4.4.4.4        : Serial0/0 (next hop 10.0.23.3)
R2#sh ip cef exact-route 2.2.2.4 4.4.4.4
2.2.2.4         -> 4.4.4.4        : Serial0/0 (next hop 10.0.23.3)
R2#sh ip cef exact-route 2.2.2.5 4.4.4.4
2.2.2.5         -> 4.4.4.4        : Serial0/0 (next hop 10.0.23.3)
R2#sh ip cef exact-route 2.2.2.6 4.4.4.4
2.2.2.6         -> 4.4.4.4        : Serial0/1 (next hop 10.0.24.4)


** yes , we are done with this. Now the packets are taking 2 paths to reach 4.4.4.4 on R4
Hope you got some thing by this lab and thanks for reading.



Happy Labbing  ^_^

Saturday, February 19, 2011

GRE Tunnel concept

                                                                                                               Courtesy : from Deepak blog


Topology diagram : 








Interfaces used :

1) 12.12.12.X & 23.23.23.X - OSPF neighborship
2)  50.50.50.50 & 150.150.150.150 - Tunnel source
3)  13.13.13.X - Tunnel Build
4) 11.11.11.11 & 33.33.33.33 - Data traffic between R1 & R3 spoke sites.  R2 is Provider here


OSPF & Eigrp neighborship build :

R1#sh ip ospf neigh
Neighbor ID     Pri   State           Dead Time   Address         Interface
23.23.23.1        0   FULL/  -        00:00:38    12.12.12.2      Serial0/0


R1#sh ip eigrp neigh
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   13.13.13.3              Tu13              14 00:33:52   88  5000  0  3


R2#sh ip ospf neigh   << It's Provider  Network >> OSPF link both customer sites
Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -        00:00:32    23.23.23.2      Serial0/1
1.1.1.1           0   FULL/  -        00:00:37    12.12.12.1      Serial0/0


R2#sh ip eigrp neigh   <<  It's Provider network >> So no Company running IGP Protocol

R3#sh ip ospf neigh
Neighbor ID     Pri   State           Dead Time   Address         Interface
23.23.23.1        0   FULL/  -        00:00:37    23.23.23.1      Serial0/0


R3#sh ip eigrp neigh
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   13.13.13.1              Tu13              12 00:30:50   94  5000  0




Configuration :

R1:

interface Loopback11
 ip address 11.11.11.11 255.255.255.255
!
interface Loopback50
 ip address 50.50.50.50 255.255.255.0
!
interface Tunnel13
 ip address 13.13.13.1 255.255.255.0
 tunnel source Loopback50
 tunnel destination 150.150.150.150


interface Serial0/0
 ip address 12.12.12.1 255.255.255.252


router eigrp 1
 network 11.11.11.11 0.0.0.0
 network 13.13.13.1 0.0.0.0
 no auto-summary
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 12.12.12.1 0.0.0.0 area 0
 network 50.50.50.50 0.0.0.0 area 0


R2 :

interface Serial0/0
 ip address 12.12.12.2 255.255.255.252
 ip ospf 1 area 0


interface Serial0/1
 ip address 23.23.23.1 255.255.255.252
 ip ospf 1 area 0



R3:

interface Loopback33
 ip address 33.33.33.33 255.255.255.255
!
interface Loopback150
 ip address 150.150.150.150 255.255.255.0
!
interface Tunnel13
 ip address 13.13.13.3 255.255.255.0
 tunnel source Loopback150
 tunnel destination 50.50.50.50


interface Serial0/0
 ip address 23.23.23.2 255.255.255.252

router eigrp 1
 network 13.13.13.3 0.0.0.0
 network 33.33.33.33 0.0.0.0
 no auto-summary
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 23.23.23.2 0.0.0.0 area 0
 network 150.150.150.150 0.0.0.0 area 0


Testing :

Check the Routing protocols what is what : So the Customer traffic should go only by Tunnel to deal with security and leakage of cutomer data or traffic, of course this is basic tunnel people can pull the data being not secured. We will go more in future LAB on how to deal with Security by implementing GRE/IPSec tunnel.

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route


Gateway of last resort is not set
     50.0.0.0/24 is subnetted, 1 subnets
C       50.50.50.0 is directly connected, Loopback50
     33.0.0.0/32 is subnetted, 1 subnets
D       33.33.33.33 [90/297372416] via 13.13.13.3, 00:38:31, Tunnel13  <EIGRP carrying>     23.0.0.0/30 is subnetted, 1 subnets
O       23.23.23.0 [110/128] via 12.12.12.2, 01:03:55, Serial0/0
     11.0.0.0/32 is subnetted, 1 subnets
C       11.11.11.11 is directly connected, Loopback11
     12.0.0.0/30 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, Serial0/0
     13.0.0.0/24 is subnetted, 1 subnets
C       13.13.13.0 is directly connected, Tunnel13
     150.150.0.0/32 is subnetted, 1 subnets
O       150.150.150.150 [110/129] via 12.12.12.2, 01:02:06, Serial0/0


R2#sh ip route
Gateway of last resort is not set
     50.0.0.0/32 is subnetted, 1 subnets
O       50.50.50.50 [110/65] via 12.12.12.1, 01:02:40, Serial0/0
     23.0.0.0/30 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, Serial0/1
     12.0.0.0/30 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, Serial0/0
     150.150.0.0/32 is subnetted, 1 subnets
O       150.150.150.150 [110/65] via 23.23.23.2, 01:03:20, Serial0/1


R3#sh ip route
Gateway of last resort is not set
     50.0.0.0/32 is subnetted, 1 subnets
O       50.50.50.50 [110/129] via 23.23.23.1, 01:04:21, Serial0/0
     33.0.0.0/32 is subnetted, 1 subnets
C       33.33.33.33 is directly connected, Loopback33
     23.0.0.0/30 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, Serial0/0
     11.0.0.0/32 is subnetted, 1 subnets
D       11.11.11.11 [90/297372416] via 13.13.13.1, 00:41:49, Tunnel13   <EIGRP carrying>     12.0.0.0/30 is subnetted, 1 subnets
O       12.12.12.0 [110/128] via 23.23.23.1, 01:06:22, Serial0/0
     13.0.0.0/24 is subnetted, 1 subnets
C       13.13.13.0 is directly connected, Tunnel13
     150.150.0.0/24 is subnetted, 1 subnets
C       150.150.150.0 is directly connected, Loopback150


~~~~~// Filtering the Routes  // ~~~~~~~

--> How to filter the Routes if we adertise the same ip address space by mistake in different IGP protocol used for different purpose.
--> Chances are less because OSPF here is SP part and we build the GRE Tunnel and EIGRP is going by GRE Tunnel. But still need to know in order to provide solution for tricky CCIE LAB tickets.

 If you encounter such problem  :

   --> fix it by filtering tunnel Source & Destination IPs using a distribute list (Using AD or ACL or prefix-list)
Happy reading  ^-^



Q&A :

Bidirectional Forwarding Detection for OSPF

This is some thing we don't use in Infra but i would like to see what is this about :

Bi-directional Forwarding Detection (BFD) provides rapid failure detection times between forwarding engines, while maintaining low overhead. It also provides a single, standardized method of link/device/protocol failure detection at any protocol layer and over any media.

Using BFD as Part of a Network Redundancy Plan :


BFD can be an important part of an overall network redundancy plan, including other Cisco innovations like Nonstop Forwarding (NSF) and the Hot Standby Router Protocol (HSRP). BFD should be deployed in those sections of the network where subsecond failure detection is required, but cannot be provided by traditional Layer 2 mechanisms. Being said that it need Layer 3 Routing in place.

Configration :
R1#sh run | s r o
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 12.1.1.1 0.0.0.0 area 0
 
bfd all-interfaces
R1#sh ip int brie | e un
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.1.1.1        YES manual up                    up 

R2#sh run | s r o
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 12.1.1.2 0.0.0.0 area 0
 
bfd all-interfaces
R2#sh ip int brie | e un
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.1.1.2        YES manual up                    up
R2#

Testing :
R1#sh ip ospf interface fa 0/0
FastEthernet0/0 is up, line protocol is up
  Internet Address 12.1.1.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State BDR, Priority 1,
BFD enabled
R2#sh ip ospf int fa 0/0
FastEthernet0/0 is up, line protocol is up
  Internet Address 12.1.1.2/24, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1,
BFD enabled  Designated Router (ID) 2.2.2.2, Interface address 12.1.1.2
Thanks for reading :)
Q&A time ::

Thursday, February 17, 2011

OSPF Virtual-link Concept

I just simulated simple OSPF virtual-link concept.

Objective :  Creating Virtual link taking "Area 2" as transit. So Area 1 Networks are reachable from Backbone and RTR-B LSDB contains non backbone area information which is passible by using Virtual-links configuration.



















Configuration :

RTR-A

RTRA#sh run | s r o
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 area 2 virtual-link 2.2.2.2
 network 11.11.11.1 0.0.0.0 area 1
 network 12.12.12.1 0.0.0.0 area 2


RTRA#sh ip int brie | e un
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.1      YES manual up                    up
FastEthernet0/1            unassigned      YES unset  administratively down down
Loopback0                  11.11.11.1      YES manual up                    up


RTR-B :

RTRB#sh run | s r o
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 2 virtual-link 1.1.1.1
 network 12.12.12.2 0.0.0.0 area 2
 network 22.22.22.22 0.0.0.0 area 0



RTRB#sh ip int brie | e un
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            12.12.12.2      YES manual up                    up
Loopback0                  22.22.22.22     YES manual up                    up


Testing :

RTR-A


RTRA#sh ip ospf virtual-links
Virtual Link OSPF_VL1 to router 2.2.2.2 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 2, via interface FastEthernet0/0, Cost of using 10
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:05
    Adjacency State FULL (Hello suppressed)
    Index 1/2, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec


RTRA#ping 22.22.22.22
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/48/88 ms


RTR-B:

RTRB#ping 11.11.11.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/45/84 ms



RTRB#sh ip route ospf
     11.0.0.0/32 is subnetted, 1 subnets
O IA    11.11.11.1 [110/11] via 12.12.12.1, 00:08:56, FastEthernet0/0

OSPF LSDB & Neighbor details :

RTRA#sh ip ospf neig
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -           -        12.12.12.2      OSPF_VL1
2.2.2.2           1   FULL/DR         00:00:38    12.12.12.2      FastEthernet0/0


RTR-A:

RTRA#sh ip ospf data
            OSPF Router with ID (1.1.1.1) (Process ID 1)
                Router Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         260         0x80000004 0x00618D 1
2.2.2.2         2.2.2.2         1     (DNA) 0x80000004 0x00A1DE 2

                Summary Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
11.11.11.1      1.1.1.1         468         0x80000001 0x00DD38
12.12.12.0      1.1.1.1         468         0x80000001 0x000C02
12.12.12.0      2.2.2.2         616   (DNA) 0x80000002 0x00EB1D

                Router Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         468         0x80000003 0x00C044 1

                Summary Net Link States (Area 1)
Link ID         ADV Router      Age         Seq#       Checksum
12.12.12.0      1.1.1.1         468         0x80000001 0x000C02
22.22.22.22     1.1.1.1         257         0x80000001 0x00E1F3

                Router Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         261         0x80000005 0x003E8F 1
2.2.2.2         2.2.2.2         262         0x80000004 0x0002C3 1

                Net Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum
12.12.12.2      2.2.2.2         628         0x80000002 0x00FF02

                Summary Net Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum
11.11.11.1      1.1.1.1         469         0x80000001 0x00DD38
22.22.22.22     2.2.2.2         878         0x80000002 0x005D7D


RTR-B:

RTRB#sh ip route ospf
     11.0.0.0/32 is subnetted, 1 subnets
O IA    11.11.11.1 [110/11] via 12.12.12.1, 00:08:56, FastEthernet0/0


RTRB#sh ip ospf data
            OSPF Router with ID (2.2.2.2) (Process ID 1)
                Router Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         1     (DNA) 0x80000004 0x00618D 1
2.2.2.2         2.2.2.2         556         0x80000004 0x00A1DE 2

                Summary Net Link States (Area 0)
Link ID         ADV Router      Age         Seq#       Checksum
11.11.11.1      1.1.1.1         208   (DNA) 0x80000001 0x00DD38
12.12.12.0      1.1.1.1         208   (DNA) 0x80000001 0x000C02
12.12.12.0      2.2.2.2         1171        0x80000002 0x00EB1D

                Router Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         556         0x80000005 0x003E8F 1
2.2.2.2         2.2.2.2         556         0x80000004 0x0002C3 1

                Net Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum
12.12.12.2      2.2.2.2         921         0x80000002 0x00FF02

                Summary Net Link States (Area 2)
Link ID         ADV Router      Age         Seq#       Checksum
11.11.11.1      1.1.1.1         765         0x80000001 0x00DD38
22.22.22.22     2.2.2.2         1172        0x80000002 0x005D7D


Q & A time

- I can explain if you have any questions and thanks for reading :)