Objective:
How EIGRP metric influence the Routing from R2 --> R4 by changing the metric Values from Default to customized.
We are going to change only DELAY rather bandwidth, this is easy to influence and verify the paths.
Topology:
Interface configuration ::
R1#sh prot | e do
Global values:
Internet Protocol routing is enabled
Serial0/0 is up, line protocol is up
Internet address is 10.0.12.1/24
Loopback1 is up, line protocol is up
Internet address is 1.1.1.1/32
R2#sh prot | e do
Global values:
Internet Protocol routing is enabled
Serial0/0 is up, line protocol is up
Internet address is 10.0.23.2/24
Serial0/1 is up, line protocol is up
Internet address is 10.0.24.2/24
Serial0/2 is up, line protocol is up
Internet address is 10.0.12.2/24
Loopback2 is up, line protocol is up
Internet address is 2.2.2.2/32
R3#sh prot | e do
Global values:
Internet Protocol routing is enabled
Serial0/0 is up, line protocol is up
Internet address is 10.0.23.3/24
Serial0/1 is up, line protocol is up
Internet address is 10.0.34.3/24
Loopback3 is up, line protocol is up
Internet address is 3.3.3.3/32
R4#sh prot | e do
Global values:
Internet Protocol routing is enabled
Serial0/0 is up, line protocol is up
Internet address is 10.0.24.4/24
Serial0/1 is up, line protocol is up
Internet address is 10.0.34.4/24
Loopback4 is up, line protocol is up
Internet address is 4.4.4.4/32
EIGRP Configuration ::
R1#sh run | s r e
router eigrp 1
network 1.1.1.1 0.0.0.0
network 10.0.12.0 0.0.0.255
no auto-summary
R2#sh run | s r e
router eigrp 1
network 2.2.2.2 0.0.0.0
network 10.0.12.0 0.0.0.255
network 10.0.23.0 0.0.0.255
network 10.0.24.0 0.0.0.255
no auto-summary
R3#sh run | s r e
router eigrp 1
network 3.3.3.3 0.0.0.0
network 10.0.23.0 0.0.0.255
network 10.0.34.0 0.0.0.255
no auto-summary
R4#sh run | s r e
router eigrp 1
network 4.4.4.4 0.0.0.0
network 10.0.24.0 0.0.0.255
network 10.0.34.0 0.0.0.255
no auto-summary
=> In order to reach 4.4.4.4 Network available in R4, R2 have to paths but based FD & Successors paths
R2#sh ip route 4.4.4.4
Routing entry for 4.4.4.4/32
Known via "eigrp 1", distance 90, metric 2297856, type internal
Redistributing via eigrp 1
Last update from 10.0.24.4 on Serial0/1, 00:00:02 ago
Routing Descriptor Blocks:
* 10.0.24.4, from 10.0.24.4, 00:00:02 ago, via Serial0/1
Route metric is 2297856, traffic share count is 1
Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
=> Check out the available paths here.
R2#sh ip eigrp top al
IP-EIGRP Topology Table for AS(1)/ID(10.0.24.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 1.1.1.1/32, 1 successors, FD is 2297856, serno 9
via 10.0.12.1 (2297856/128256), Serial0/2
P 2.2.2.2/32, 1 successors, FD is 128256, serno 8
via Connected, Loopback2
P 3.3.3.3/32, 1 successors, FD is 2809856, serno 57
via 10.0.24.4 (2809856/2297856), Serial0/1
via 10.0.23.3 (6905856/128256), Serial0/0
P 4.4.4.4/32, 1 successors, FD is 2246656, serno 55
via 10.0.24.4 (2297856/128256), Serial0/1
P 10.0.12.0/24, 1 successors, FD is 2169856, serno 1
via Connected, Serial0/2
P 10.0.24.0/24, 1 successors, FD is 2169856, serno 3
via Connected, Serial0/1
P 10.0.23.0/24, 1 successors, FD is 6777856, serno 52
via Connected, Serial0/0
via 10.0.24.4 (3193856/2681856), Serial0/1
P 10.0.34.0/24, 1 successors, FD is 2681856, serno 58
via 10.0.24.4 (2681856/2169856), Serial0/1
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
via 10.0.23.3 (11897856/6777856), Serial0/0, serno 59
** Now i want ot influence the paths by calculating the existing Reported distance and Feasible distance
** So that i can LOAD-BALNCE the traffic to reach 4.4.4.4 by
R2 -> R4 and
R2 -> R3 -> R4
** I will change the Delay from 20000 to 10000 on R3 ( S 0/1 ) Interfaces which takes to R4 paths.
Testing ::
R2#sh ip eigrp top al
IP-EIGRP Topology Table for AS(1)/ID(10.0.24.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 1.1.1.1/32, 1 successors, FD is 2297856, serno 9
via 10.0.12.1 (2297856/128256), Serial0/2
P 2.2.2.2/32, 1 successors, FD is 128256, serno 8
via Connected, Loopback2
P 3.3.3.3/32, 1 successors, FD is 2809856, serno 57
via 10.0.24.4 (2809856/2297856), Serial0/1
via 10.0.23.3 (6905856/128256), Serial0/0
P 4.4.4.4/32, 1 successors, FD is 2246656, serno 55
via 10.0.24.4 (2297856/128256), Serial0/1
via 10.0.23.3 (7161856/2041856), Serial0/0 <<----- Wow there are 2 paths meeting the requirements to become FS
P 10.0.12.0/24, 1 successors, FD is 2169856, serno 1
via Connected, Serial0/2
P 10.0.24.0/24, 1 successors, FD is 2169856, serno 3
via Connected, Serial0/1
via 10.0.23.3 (7545856/2425856), Serial0/0
P 10.0.23.0/24, 1 successors, FD is 6777856, serno 52
via Connected, Serial0/0
via 10.0.24.4 (3193856/2681856), Serial0/1
P 10.0.34.0/24, 1 successors, FD is 2681856, serno 58
via 10.0.24.4 (2681856/2169856), Serial0/1
via 10.0.23.3 (7033856/1913856), Serial0/0, serno 59
R2#sh ip route 4.4.4.4
Routing entry for 4.4.4.4/32
Known via "eigrp 1", distance 90, metric 2297856, type internal
Redistributing via eigrp 1
Last update from 10.0.24.4 on Serial0/1, 00:00:33 ago
Routing Descriptor Blocks:
* 10.0.24.4, from 10.0.24.4, 00:00:33 ago, via Serial0/1 <<-- Still only one path and NO traffic load-balance
Route metric is 2297856, traffic share count is 1
Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
** Let us meet the requirement again to install to Routes in Routing table so i will change the Delay from 20000 to 10000 on R2 ( S 0/0 )
R2#sh ip route 4.4.4.4
Routing entry for 4.4.4.4/32
Known via "eigrp 1", distance 90, metric 2297856, type internal
Redistributing via eigrp 1
Last update from 10.0.23.3 on Serial0/0, 00:00:03 ago
Routing Descriptor Blocks:
* 10.0.24.4, from 10.0.24.4, 00:00:03 ago, via Serial0/1
Route metric is 2297856, traffic share count is 1
Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1
10.0.23.3, from 10.0.23.3, 00:00:03 ago, via Serial0/0 <-- We made it now we have 2 paths to reach 4.4.4.4
Route metric is 2297856, traffic share count is 1
Total delay is 25000 microseconds, minimum bandwidth is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 2
R2#sh ip cef exact-route 2.2.2.2 4.4.4.4
2.2.2.2 -> 4.4.4.4 : Serial0/0 (next hop 10.0.23.3)R2#sh ip cef exact-route 2.2.2.1 4.4.4.4
2.2.2.1 -> 4.4.4.4 : Serial0/1 (next hop 10.0.24.4)R2#sh ip cef exact-route 2.2.2.3 4.4.4.4
2.2.2.3 -> 4.4.4.4 : Serial0/0 (next hop 10.0.23.3)
R2#sh ip cef exact-route 2.2.2.4 4.4.4.4
2.2.2.4 -> 4.4.4.4 : Serial0/0 (next hop 10.0.23.3)
R2#sh ip cef exact-route 2.2.2.5 4.4.4.4
2.2.2.5 -> 4.4.4.4 : Serial0/0 (next hop 10.0.23.3)R2#sh ip cef exact-route 2.2.2.6 4.4.4.4
2.2.2.6 -> 4.4.4.4 : Serial0/1 (next hop 10.0.24.4)
** yes , we are done with this. Now the packets are taking 2 paths to reach 4.4.4.4 on R4
Hope you got some thing by this lab and thanks for reading.
Happy Labbing ^_^
No comments:
Post a Comment